Site is down
Incident Report for Vero
Resolved
An application upgrade failed, we identified this immediately and rolled back to the previous version. The site is now fully operation :).
If you have any questions please don't hesitate to contact support@getvero.com
Posted over 3 years ago. May 28, 2015 - 17:07 AEST
Investigating
The Vero website is currently down and will be back online as soon as possible.
Posted over 3 years ago. May 28, 2015 - 16:56 AEST