Helpdesk offline
Incident Report for Vero
Resolved
Access to our help desk software has been restored and we are now working through the backlog of tickets.
Posted almost 5 years ago. Feb 22, 2014 - 09:33 AEDT
Investigating
Our help desk software is currently unavailable. All emails to support@getvero.com will be delayed until the software has been restored. If you have any urgent issues, please forward your emails to james@getvero.com.
Posted almost 5 years ago. Feb 21, 2014 - 23:18 AEDT