Delays in email sending and certain aspects of UI are not loading

Incident Report for Vero

Resolved

We have confirmed the source of the issue and deployed a fix. This issue is now fully resolved and all message are real time.
Posted Nov 26, 2025 - 01:07 UTC

Investigating

We're investigating minor delays in message sending and reports that certain elements of the UI (Logs, Profiles) are not loading correctly.
Posted Nov 26, 2025 - 00:53 UTC
This incident affected: Vero 1.0: Automated email processing (Transactional emails, Workflows, Behavioral emails), Vero 1.0: UI (Logs page activity), and Vero 1.0: Newsletter processing, Vero 2.0: UI, Vero 2.0: Newsletter processing, Outgoing webhooks.