Delivery metrics under-reporting

Incident Report for Vero

Resolved

All stats should now be caught up. We have monitored overnight and observed no additional issues.
Posted May 30, 2025 - 05:00 AEST

Monitoring

This issue has been identified and patched. We are currently monitoring to ensure the issue has been fully addressed. In the meanwhile, delivery stats are being backfilled but will take some hours before they are fully accurate.
Posted May 29, 2025 - 08:29 AEST

Identified

We are receiving multiple reports that the "Delivery" metric in the Vero UI and integrations via webhooks are currently under-reporting.

We have identified the cause of this issue. At this time it appears it relates to reporting only: messages are still being successfully delivered.

We will provide an update as soon as we have deployed a fix and are monitoring the solution.

Please email support@getvero.com with any questions.
Posted May 28, 2025 - 19:40 AEST
This incident affected: Vero 1.0: Reports data availability (Reports data availability (Vero default and Mailgun integrations)) and Vero 2.0: Reports data availability.