Email template discrepancies
Incident Report for Vero
Resolved
At 03:30 UTC today (Thursday) we deployed the full release of our new drag-and-drop editor and campaign editing workflow.

This is a huge change at all layers of our application. Despite weeks of rigorous QA, we ran into two minor edge cases today:

1. *Inability to send automated emails that used a template*. Automated messages that used a template (any template) could not find their email content and were failing to send. We manually fixed campaigns as we identified them and fully resolved this issue at approximately 08:00 UTC today. Any affected sends were retried and no emails were sent with incorrect content.

2. *Issues rendering old, `vero-editable` templates*. Our old editor didn't support `vero-editable` tags _within_ `vero-editable` tags. Our new release is more stringent in enforcing this, causing templates with nested `vero-editable` tags to render strangely. This issue was resolved around 10:30 UTC today. No campaign content was lost or altered *unless* a campaign was opened, viewed in its "garbled" form and saved during the 03:30-10:30 UTC window today. If this occurred for you, please email us and let us know.

We will continue to resolve any bugs related to the new release if and when they are reported. We are resolving this issue as there are no longer any issues with email rendering or sending.

Thanks and we hope you enjoy the new editor and workflow! 🎨
Posted Jun 04, 2020 - 23:07 AEST
Monitoring
Your campaign content is now rendering as expected in the UI 🥳.

If you saved your campaign between 3:45am-11:20am UTC the content may be cached in the UI. Please contact support@getvero.com and we can manually refresh them.

We'll be following up with further details on what occurred.
Posted Jun 04, 2020 - 21:30 AEST
Identified
Emails that were previously being discarded are now sending as expected. We should have further updates on editing content shortly.
Posted Jun 04, 2020 - 19:42 AEST
Investigating
We're investigating reports that some email templates are rendering differently than expected. If this is the case you should see these emails being discarded instead of sent. This ensure's that users will not receive incorrect content.

Please email support@getvero.com if you have any questions regarding your account or emails.
Posted Jun 04, 2020 - 16:34 AEST
This incident affected: Vero Cloud: Automated email processing (Transactional emails, Behavioral emails, Workflows) and Vero Cloud: Newsletter processing.