Newsletter Delays
Incident Report for Vero
Resolved
Our upstream provider has reported that they are continuing to monitor their mitigation efforts. Over the last 24 hours, we've seen a return to normal sending and no substantial newsletter delays. We'll continue to monitor the situation, and provide future updates should we begin to experience delays again.
Posted Feb 24, 2023 - 12:09 AEDT
Update
While we continue to experience some intermittent issues with our upstream provider, we've seen a significant improvement in processing speed since yesterday morning. Our upstream provider has reported that they are continuing to investigate and monitor the situation, and we will be monitoring as well.
Posted Feb 23, 2023 - 06:34 AEDT
Investigating
At approximately 15:00 UTC, we noticed an increasing number of connection errors with an upstream provider resulting in serious email delays for newsletters. This provider has since provided a status update that they have "Implemented DDoS protection and monitoring results", but we are continuing to see intermittent connection errors and have reached out to the upstream provider to gather more details.

In the interim, expect long delays on newsletter sending in both our Cloud and Connect products.
Posted Feb 22, 2023 - 07:58 AEDT
This incident affected: Vero Cloud: Newsletter processing and Vero Connect: Newsletter processing.