Delays in API and message processing

Incident Report for Vero

Resolved

Everything is operating as normal at this time and has been for the last couple of hours.
Posted Aug 05, 2025 - 16:30 UTC

Monitoring

We've made a fix and things are trending back to normal.

We're keeping the status as "Degraded performance" for the time being but are monitoring and will mark as resolved as soon as we can.

Thanks for your patience.
Posted Aug 05, 2025 - 13:43 UTC

Identified

We are experiencing delays processing API calls and downstream workflows.

We know this is frustrating. We have identified the issue and are working to restore processing as soon as possible.
Posted Aug 05, 2025 - 12:34 UTC
This incident affected: Vero 1.0: Ingestion API, Vero 1.0: Automated email processing (Transactional emails, Workflows, Behavioral emails), and Vero 1.0: UI (Logs page activity).