Delays processing Behavioral emails
Incident Report for Vero
Resolved
We are now closing this incident.

Email processing has been stable and operating as normal for nearly two weeks now.

If you have questions regarding the earlier impact of this issue or otherwise, please email us at support@getvero.com.

Thank you.
Posted Oct 24, 2019 - 22:44 AEDT
Update
We will continue to monitor and assess the impact of this weekend's maintenance (see: https://status.getvero.com/incidents/hc9ytgz3fw55) on our email processing performance and post another update early next week.
Posted Oct 20, 2019 - 04:12 AEDT
Monitoring
Email processing has been consistent and stable since our previous update but we are continuing to monitor closely, we will also be scheduling related maintenance this Saturday 19th October (see: https://status.getvero.com/incidents/hc9ytgz3fw55).
Posted Oct 15, 2019 - 22:45 AEDT
Update
We have made a series of updates to email processing over the past 48 hours and have been monitoring their impact. There are further improvements planned in the coming days and we will continue to keep you updated.

If you have any questions about your account please email support@getvero.com and our on call team will be able to assist
Posted Oct 12, 2019 - 09:23 AEDT
Update
We have made headway on this issue today.

At approximately 05:15 UTC we conducted some emergency maintenance to help resolve this incident. This resulted in a short period of unexpected downtime on our API. Between 05:15 and 05:40 UTC our API returned 502 or 504 errors.

If you use our Javascript, retry API requests or use Segment.com to send Vero data, all requests should be automatically retried and processed.

If you have any questions please email us at support@getvero.com.

We will provide further updates regarding the overall incident once we have gathered more data.
Posted Oct 10, 2019 - 17:14 AEDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 09, 2019 - 20:14 AEDT
Identified
We're currently experiencing periodic and ongoing delays in processing:

• Behavioral emails.
• Behavioral, Transactional and Workflow emails utilising the "send relative to variable" functionality.

Note that these delays are not constant, they are intermittent.

We have been seeing this issue on-and-off over the past two and a half weeks, and have been working to determine the root cause (or causes). This issue has now crossed our internal thresholds based on its reoccurrence and affect on customers – as such we are escalating this and raising a formal incident for communication.

Our team is actively working to resolve this. If you have questions or want to discuss potential or observed impact on your account please email us at support@getvero.com.

We will provide more details as they become available.
Posted Oct 09, 2019 - 18:23 AEDT
This incident affected: Triggered email processing (Behavioral emails, Workflows).