Campaign reports loading slower than normal
Incident Report for Vero
Resolved
This incident has now been resolved, we will continue to monitor ongoing performance.
Posted 9 months ago. Oct 17, 2018 - 14:05 AEDT
Identified
We wanted to let you know that we aware that detailed campaign reports are currently taking 15-30 seconds to load.

Typically reports take a maximum of 10 seconds to load on average, and this is our internal benchmark for all reports, regardless of size or custom inputs (such as custom date ranges).

We are working to restore speed to normal and apologise for the inconvenience caused. If you have questions or can't access reports, please let us know via email at support@getvero.com.
Posted 9 months ago. Oct 12, 2018 - 17:59 AEDT