Maintenance on Customer Search
Incident Report for Vero
Resolved
Things have been stable for the last couple of weeks and we're quite comfortable that our migration is holding steady.

We have some more maintenance planned in the near future and will update you at that time.
Posted over 1 year ago. Sep 02, 2016 - 10:57 AEST
Update
We have identified a regression based on our changes over the weekend. We are reviewing this now and have temporarily put the maintenance page whilst we do so.

We apologize for the inconvenience caused.
Posted over 1 year ago. Aug 17, 2016 - 14:22 AEST
Update
Maintenance on customer search has been completed. The team will continue to monitor for intermittent issues.
Posted over 1 year ago. Aug 13, 2016 - 05:02 AEST
Monitoring
Hi all,

Over the last 24 hours we have seen intermittent issues with the cluster that powers Vero's customer search. This cluster is used to enable our Logs page and the customers search widget, including the search widget used for previews.

This is an update to inform you that:

- Logs are working correctly again.
- Customer search is working, though with degraded performance on partial searches.

We are moving the status of "Activity Logs" back to "Degraded performance" at this time.

We have determined the cause of the intermittent degredation and are now undertaking some unexpected maintenance in the background. We believe this is the best long term decision for your experience at Vero.

During this time the performance on the customer search will be slower in certain scenarios, so here are a few tips to ensure your workflow is as uninterrupted as possible!

1. If you search for any email address that is an exact match, the search should be super fast and will guaranteed return a result if it is in our databases.
2. Searching for partial matches, e.g. `gmail.com` will take longer and may not return complete results from our database whilst the maintenance is ongoing.
3. If you're previewing an email in the browser, a secret trick is to append `?user_id=1234` in the URL. This ID is the URL you get from a customer's profile in Vero, e.g. https://app.getvero.com/customers/THIS-IS-THE-ID

We are anticipating our maintenance to conclude within the next 24 hours. There will be no change to your experience other than results will be complete at that time (as per two above). We will post an update at that time via our status page at status.getvero.com.

Thanks,

James

--
CTO, Vero
support@getvero.com
Posted over 1 year ago. Aug 11, 2016 - 15:57 AEST